Win 7 problems

5 replies [Last post]
terorvlad
Offline
Joined: 08/07/2010
Posts: 44

Problems, that is the new feature that comes with win7. I had to install both xp and 7. Ok, Let me start:

1 Everytime I start the pc, the ATI catalyst errors and closes itself ( I tryed 3 catalyst versions , uninstalled and reinstalled them 5 times and still I get that error) no errors in XP

2 Wireframe made by dots in Stalker CoP in dx 11 , If i turn to dx 10 or 9 the dots dissapear. They do not appear in XP

3 Crysis warhead Black and White artefacts. They appear only on one specific tree model. I don't get them on XP(no problems in crysis 1 demo)

4 Artefacts in fallout 3. After shooting for exampe someones hand, A big white dot appears. I don't get them on xp.

Will reinstalling win 7 solve this problems or there is something wrong with the catalyst(impossible) ?

CPU: I5-760 @3.4 Ghz | MoBo: Msi H55M-p31
GPU: 5870 Sapphire | Ram: 8 Gb @1333Mhz
Case&PSU: Antec Sonata 3-500W | OS: Windows 7 Ultimate 64
Cooler: Deepcool Icefrige mini FS| Monitor: 23.7' LG Flatron W2443T 1080p LCD

viperrcr
Offline
Joined: 10/29/2005
Posts: 70

Silly question, but ya never know...
Did you download the correct Catalyst driver for your video card (Win 7 64-bit) directly from the ATI webpage?

terorvlad
Offline
Joined: 08/07/2010
Posts: 44

I first installed from AMD homepage, then installed from CD , then from guru3d and finaly from Steam (Steam has the ati drivers update feature now)

viperrcr
Offline
Joined: 10/29/2005
Posts: 70

Maybe try uninstalling Catalyst completely and rebooting. Let windows detect a generic card and then do a registry/file cleaner such as CCleaner ( http://www.piriform.com/download ) - it is free, be sure to check ALL the options for the registry/file scans (when chooseing file scan, do not check wipe free space as this will takea very long time) run registry scans multiple times until no errors are found (especially when cleaning the retistry, seems cleaning something opens the door for something after that cleaning and needs to be cleaned), so basically keep cleaning registry until it finds no errors.
Reboot after fully cleaned and then reinstall Catalyst from AMD website.
http://sites.amd.com/us/game/downloads/Pages/radeon-win7-64.aspx
Also check temps of your GPU, mayne you need to manually set your fan speed higher.
I know might be long shot, but got nothing to lose...

terorvlad
Offline
Joined: 08/07/2010
Posts: 44

Didn't worked, but the thing that caught my attention is that right before installing the catalyst (I had it uninstalled withe no registery errors) I opened crysis to see what happens (In xp i can't play any 3d game if I don't install the drivers) and it worked (Still getting artefacts). Is it normal in win7 to be able to play games before installing the drivers ? And I am very sure that the catalyst was uninstalled when I played it.

One way or another, it seems that reinstalling win7 is the only solution that might work.

viperrcr
Offline
Joined: 10/29/2005
Posts: 70

At this point, I think I might agree with you...Any patches for the games maybe? If not try a System Restore to a point when it worked, if not, restore an image or then it might be time to reformat/reinstall... :(