FPS Limiter???

6 replies [Last post]
Barbara917
Offline
Joined: 09/23/2009
Posts: 62

It is incredibly bad how bad the new The Sims 3 expansion World Adventures is in the bug department.

It appears that Nvidia even had to release a new driver to prevent their graphics cards from being burnt up by the game. Seriously. I am not talking about some benchmarking game like Crysis. I am talking about The Sims 3 World Adventures Expansion.

There is a command that can be entered in the cheat console of the game that supposedly reports the framerate that the game is running at called fps on. If my game can be believed my framerate is hovering at 300 fps. That's sitting there idle staring at a pretty static picture save for a few sims walking around.

So what does anyone know about FPS Limiter programs? I have started googling to try to learn about them but my initial looks indicate they aren't available for Window 7 64-bit.

Core i7 920
Asus Rampage II Gene
XFX Radeon HD 5850
Windows 7 64-bit Home Premium

Skull Abyss Pro...
Offline
Joined: 01/26/2010
Posts: 48

What you might want to do is enable the vertical refresh sync cause from my understanding it'll keep the max frame-rate at the refresh rate the monitor is currently set at. I'm pretty sure you can enable it in the drivers and in the game in the video settings so try that to see if it'll work. If that doesn't work try under-clocking both your GPU and CPU to see if that will help. or even try maxing the screen res out and having all setting all the way maxed out with AA and AF maxed out if possible

Skull Abyss

d3uS2029
d3uS2029's picture
Offline
Joined: 03/20/2003
Posts: 291

You risk burning your card out by getting too high of an FPS?

thats news to me.

try this. Vsync: ON

:.: Intel i7 920 @ 3.8Ghz :.: 12GB Corsair XMS3 @ 1704Mhz :.: ASUS P6T V2 Deluxe :.: ASUS 5870EAH :.: 120GB Vertex 2 (OS) :.: 120GB OCZ Agility (Games) :.: 2x WD Black 2TB (Data) :.: Zalman 850w PSU :.: Lite-On Blu-Ray Burner :.: HP w2207h LCD :.:

Barbara917
Offline
Joined: 09/23/2009
Posts: 62

This is how bad it is. World Adventures was programmed without Vsync. You cannot turn it on within the game.

And I don't know that I would risk burning MY card out. I built this rig with pretty good ventilation. It stays cool. I never hear the graphics card fan kick into high gear.

I think the Nvidia cards that were being burnt out were probably casual gaming graphics cards. I didn't pay too close attention because I don't have Nvidia myself. I am still confused as to how people could burn out their cards without hearing the fans run on high for an extended period. But I think these were probably PC's not built for intensive gaming and didn't have a lot of ventilation.

In defense of all the people that burnt up their cards. They were playing The Sims 3 for goodness sake. Who would reasonably expect that that game would burn up their cards?

Skull Abyss Pro...
Offline
Joined: 01/26/2010
Posts: 48

You should be able to enable Vsync in the driver software if need be

dustyschaffner
dustyschaffner's picture
Offline
Joined: 06/02/2009
Posts: 334

high framerates cant fry a video card. if that were the case then everyone would be buying a new card every day. desktop framerates alone can reach over 2,000.

i dont believe these tests were run on your average high end gaming system, i believe it was done on computers that arent built for heavy gaming, like a dell optiplex 755 or something

Barbara917
Offline
Joined: 09/23/2009
Posts: 62

Well I would be far more inclined to believe you all than what I read at The Sims 3 forums. There was a driver update issued by Nvidia to do with some problem with The Sims 3 but I could well have misunderstood the purpose or cause of the problem.

In defense, I read about all these people insisting the need for FPS limiter software to protect their graphics cards so I thought I would check into it. I am really curious as to the purpose of an FPS limiter program.

On an off-topic note. The other problem I was having with this game is constant crashes to the desktop. Many people on those forums were insisting the high framerates spit out by the game were the cause. I spent hours combing through their forums trying to find some solutions. Incredibly what seems to have fixed my crashes was to turn off two of my cores in the BIOS. Apparently, World Adventures doesn't like four cores because my desktop crashes went away.