Graphics Card's GPU Clock

2 replies [Last post]
mikekennedy
Offline
Joined: 07/02/2012
Posts: 6

Hi everyone

I have a ATI Mobility Radeon HD 4570 in my laptop, and today after I played a Source game (CS:S) a noticed that the GPU clock wouldn't go above 300 MHz (220 Mhz idle and 680 Mhz load), the memory clock wouldn't go above 300 MHz (300 MHz idle and 800 MHz load) and the VDDC (voltage) stayed at minimum (0.950 V)

During the game, my CPU load was about 50-60%. I have the game in the recommended settings. I've tried updating the graphics card driver, the chipset driver, and nothing. Can anyone help me figure this out?

By the way, this is my first post, and sorry about my English :)

spawnkiller
spawnkiller's picture
Offline
Joined: 05/06/2012
Posts: 310

if you have the "AMD" dirver it's because your card doesn't need to be at higher speed to play this game (it clock itself higher when load increase) If you don't have a good FPS you can try to set "Maximum performance in the power setting of windows, sometimes it resolve the problem... if that doesn't work, you still can disable 2D clock to run all the time at Max clock but it's a little more tricky (i don't know your experience and if you're ok with bios/driver mod)

PS: you can use the CCC to overclock or search for a performance setting (Nvidia have one and you can set it to Maximum performance that almost disable 2D (only idle and full core clock i think) or maybe if your laptop is a good one (i know ASUS have the option "Disable 2D clock" in their GPU tweak software and MSI too)

Gaming PC: MSI Z77A-G45 ::: Intel Core I7 3770k @ 4.83Ghz ::: EVGA GTX680SC Signature ~1300mhz Boost/7122mhz ram ::: 16GB 4*4gb G.Skill 2240mhz CL10 ::: ASUS Xonar DX ::: Crucial M4 128gb (windows) + Intel 330 180gb (Steam games) + 1TB Caviar Black (storage) ::: Cooler Master Silent Pro Gold M1000 ::: Antec P280 ::: Noctua NHU12P SE2 ::: ASUS VE247H ::: Logitech G510 ::: Cooler Master Storm Sentinel II ::: Logitech X530 ::: Steelseries Siberia V-2 Black & gold edition

98% Of people under 25 surround their minds with rap music, if you're part of the 2% that stayed with rock, put this in your signature, ROCK IS BETTER!

mikekennedy
Offline
Joined: 07/02/2012
Posts: 6

Problem solved. Somehow, I had "Maximum battery life" in the Windows settings. I always use "Maximum performance", don't know how it changed. Thanks :D