Driver problem driving me crazy

No replies
NexFrost
NexFrost's picture
Offline
Joined: 12/29/2008
Posts: 111

Alright, so for the past month or so my internet connection to my desktop has gotten more and more problematic. First i just had to roll back the driver and it would work. Then i had to shutdown and restart my computer. Now the driver is just gone and i cant re-install it.

 

My mother board is the "GIGABYTE GA-MA790X-UD4P" http://www.newegg.com/Product/Product.aspx?Item=N82E16813128387

I went to the driver page http://www.gigabyte.us/Support/Motherboard/Driver_Model.aspx?ProductID=3031&ost=windows+7+64bit#anchor_os and downloaded both Realtek LAN Driver & Realtek Ethernet Diagnostic Utility.

Installed the Diag Utility and ran it, it shows up blank..

 

So then I tried to install the driver and this happens:

The FindMe file would pop up first, after i pressed OK the 2nd error poped up. Then if i tried to repair it the same "Network Controller was not found" message would pop up.

 

Im all out of ideas and any help would be greatly appreciated, thanks.


Antec 900 Antec Earthwatts 500W PSU AMD Kuma 2.7 GHz 4GB G.Skill RAM 640GB Western Digital HDD HIS Radeon HD 4850 512MB GIGABYTE GA-MA790X-UD4P