CRYSIS problems

5 replies [Last post]
codmerced
Offline
Joined: 05/30/2010
Posts: 21

Im playing crysis on windows 7 and it keeps crashing. my processor is an i7-930 at 3.4ghz and i have a gtx 260 gpu. I tried it on high settings and it crashed. I dropped it to medium and it still crash. What is wrong?

MY rig: Azza Solano 1000 case, Intel core i7-930, Nvidia gtx 260, 6gb Corsair Dominator Ram, GigaByte GA-EX58-UD4P mobo, Asetek 510lc water cooling.

Tiv
Tiv's picture
Offline
Joined: 08/12/2009
Posts: 3584

Update your video drivers. Also try running it vista sp2 compatibly mode.

I sleep fine at night knowing we are banning people who deserve it.  Tivon
Don't test my skills, I was trained by myself! Check out my Gaming Videos!

Dreamer-Boy
Dreamer-Boy's picture
Offline
Joined: 10/21/2008
Posts: 928

I had a similar problem. I had an AMD Athlon 5000 X2, 2 GB DDR2 RAM and HD4650. I have no problem with the game until the last mission where I need to destroy the big alien machine. I tried many times but I cannot complete the game. It lags so much at that part. I am running Windows 7 64-bit.

[SIGPIC]-Dreamer-Boy's[/SIGPIC]

Orange Juice
Offline
Joined: 06/15/2010
Posts: 1

I had the exact same problem at that level (using Windows 7 64 bit and an 5970 card).

I 1) run the 64 bit version of Crysis (rather than the 32 bit version), and 2) set the compatibility mode for Vista SP2 - that fixed the problem.

Dreamer-Boy
Dreamer-Boy's picture
Offline
Joined: 10/21/2008
Posts: 928

Really? Lags so much man !!!!

Danny Lim
Danny Lim's picture
Offline
Joined: 04/06/2010
Posts: 129

Update your video driver!

Your day has come to learn about Technology!